Soldak Entertainment Forums

Soldak Entertainment Forums (http://www.soldak.com/forums/index.php)
-   Linux (http://www.soldak.com/forums/forumdisplay.php?f=35)
-   -   Segfault on Startup (with solution) (http://www.soldak.com/forums/showthread.php?t=31003)

OxOOO5cO77 03-14-2014 07:02 PM

Segfault on Startup (with solution)
 
Hi -

It's good to see a linux demo! Unfortunately, it was segfaulting for me right away. :(

You may remember that I was having similar problems running the windows version with wine (as documented in the thread "Crash on boot (Linux/Wine)")

The linux demo core dump provided the following backtrace
Code:

Program terminated with signal SIGSEGV, Segmentation fault.
#0  0xf75bfb45 in MixDirect_SSE () from /usr/lib32/libopenal.so.1
(gdb) bt
#0  0xf75bfb45 in MixDirect_SSE () from /usr/lib32/libopenal.so.1
#1  0xf75be143 in MixSource () from /usr/lib32/libopenal.so.1
#2  0xf75b53ee in aluMixData () from /usr/lib32/libopenal.so.1
#3  0xf75c50dc in PulseProc () from /usr/lib32/libopenal.so.1
#4  0xf75b9ad0 in StarterFunc () from /usr/lib32/libopenal.so.1
#5  0xf738df33 in start_thread () from /lib32/libpthread.so.0
#6  0xf7495a7e in clone () from /lib32/libc.so.6

A quick search indicates that it's likely unaligned (or improperly aligned) memory.

Rebuilding OpenAL without SSE support allows me to get into the game with sound. I played through a couple systems, up to about level 3, with no further issue.

My relevant system info:
Linux 3.12.13-gentoo #1 SMP Mon Mar 3 22:12:26 PST 2014 x86_64 Intel(R) Core(TM) i7-3770K CPU @ 3.50GHz GenuineIntel GNU/Linux
openal-1.15.1

Hope this helps someone (or points to a legit problem!)

Thanks again for an awesome game. :)


All times are GMT -4. The time now is 12:29 PM.

Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright 2007 - 2019 Soldak Entertainment, Inc.