Soldak Entertainment Forums

Soldak Entertainment Forums (http://www.soldak.com/forums/index.php)
-   Kivi's Underworld modding (http://www.soldak.com/forums/forumdisplay.php?f=17)
-   -   How to translate (http://www.soldak.com/forums/showthread.php?t=1146)

DetlevH 11-10-2008 02:15 PM

How to translate
 
Just bought it....

How can i translate it? Same way as Depths of Peril?

How can i switch the game language?

Shadow 11-10-2008 03:29 PM

It's mostly the same as DoP was except now the stories directory is in Loc/English.

Once you have multiple directories in the Loc directory, it will give you a choice of which language to use in the upper left corner of the main menu screen.

You should also be able to change the loc_language user var from the console when you are in the game. For example, typing
loc_language English
in the console and hitting enter would change the language to English.

DetlevH 11-11-2008 07:00 AM

Not working
 
2 Attachment(s)
It seems not to work.

I just duplicated the English folder and renamed it to german.

Please copy the attached zip file to the assets folder and try it out.

Seems, there is something wrong here........:confused:

After that i deleted the mod_german.zip file and after the restart of Kivi the console shows this error messages (see attached screenshot) and many text is missing:mad:

What's wrong here?

Shadow 11-11-2008 10:07 AM

Ok, the localization stuff seems to work fine, but the choose language box isn't working with the zip files. It is adding a trailing / to the language names so it isn't changing the language correctly. I will fix this in the first patch.

Setting the language using the console works fine though. At the console use the following commands (depending on which language you want to set of course):
loc_language English
loc_language german

DetlevH 11-11-2008 10:17 AM

During playing i get more and more of these error messages in the console (see email before).

Now my game seems to be totally destroyed, even with the deleted mod_german.zip.

I can't use the keyboard anymore.....

Shadow 11-11-2008 10:40 AM

If you can't change loc_language back to English in the console, just open up User/user.cfg and change it in there. Everything should be back to normal then.

DetlevH 11-12-2008 01:23 AM

Yes, that's true. It works now.

Thanks!

DetlevH 11-12-2008 05:27 AM

AdventureEpilog4 in global.trn has a trailing s for the Plural.

That's wrong for german.

Shadow 11-12-2008 10:52 AM

The s is in the text and not the code part so you can safely take that out for the German translation.

DetlevH 11-12-2008 01:06 PM

Shadow, before you release the first patch, please check if every screen text is in the text files under the Loc\[language] folder.:)

I translated

OneLifeLeft "1 Leben übrig"
XLivesLeft "##1## Leben übrig"

in global.trn but it's still english on the screen.:confused:


All times are GMT -4. The time now is 05:00 AM.

Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright © 2007 - 2019 Soldak Entertainment, Inc.