Soldak Entertainment Forums

Soldak Entertainment Forums (
-   Zombasite (
-   -   Orc Schism Bugs (

Castruccio 12-26-2017 07:35 PM

Orc Schism Bugs
1 Attachment(s)
I thought I'd start this thread for Orc Schism bugs. There is currently a thread on the Steam forums with several bugs as well (I believe the title of the thread is "Glitches.") So far though, the expansion is great and a lot of fun.

At any rate, I have attached a screenshot of a gate spawning inside a wall.

ScrObot 12-30-2017 06:38 AM

I came across another clan's town that had two teleport gates spawned nearly on top of each other (just a couple pixels off). In addition, I could not interact with their Bounty Board. Checking their quests in the Clan screen showed none available, however their town was overrun with squishable bugs, which is typically tied to a quest.

fbo 12-30-2017 10:55 AM

After the "destroy tunnel" quest is completed the tunnel is still visible on the map.

Crisses 12-30-2017 11:24 AM


Originally Posted by ScrObot (Post 83104)
I came across another clan's town that had two teleport gates spawned nearly on top of each other (just a couple pixels off). In addition, I could not interact with their Bounty Board. Checking their quests in the Clan screen showed none available, however their town was overrun with squishable bugs, which is typically tied to a quest.

You can shop for and turn in quests via the Relations screen. Use it often since I don't want to go to a town's board to find/fill requests. Even use it for my own town.

Crisses 12-30-2017 11:26 AM


Originally Posted by fbo (Post 83107)
After the "destroy tunnel" quest is completed the tunnel is still visible on the map.

I did the destroy tunnel quest, it turned into a filled hole picture. like a defunct mine. However another destroy tunnel quest came up for some reason.... and I couldn't see another tunnel in my town.

I should have captured the glitches on quests.

Another quest glitch: I recovered my teleport stone, cashed in the quest — so my stone's fine. My town spawned another recover teleport stone quest anyway.

I'll keep an eye out for more quest glitches.

Crisses 12-30-2017 11:34 AM

oddities, some glitches
1 Attachment(s)
Ok, ridiculous amounts of ambushes, to the point that Hulks kept filling a small room, causing avalanches, and I seriously wonder whether or not the Hulk breeding machine would overheat. :P Any space I cleared would just get filled up with more hulks.... see "Ambush!" over and over? (screenshot) I've been getting insane numbers of repeated ambushes in general. After 3 or so in a row, it should stop. I've solved the hulk quest for the level, etc. -- so why are they still coming in droves? History says 13 ambushes in a row. Come on! I just teleport stone'd out eventually. Couldn't make it back to the staircase.

When comparing doors in inventory it shows me the best door we currently have on the pedistals. It should compare a + item in inventory with the WORST item(s) we have equipped or on the pedistals — what is it recommending it's better than?

I have stay still toggle off, but it seems to happen anyway. Same for continuous firing if I quick double-click — bug or feature? A little annoying to find I can't move until I double-click again.

On the intro screen, I watched an imp turn off a lantern. I was able to turn it back on. An imp comes over and turns it off. I turn it back on. This keeps happening. What do imps have against streetlights? lol

In a game with no other clans, I had a quest to kill a Havoc Orc Shaman Hunter in the area I'm in — but the waypoint shows up in another area entirely. I think whomever SENT the hunter was listed in the quest — I was in the right area by all indicators (from gates, pointing at the current dungeon name, etc.) UNTIL the waypoint was placed in a different area/dungeon. Ugh.

Why would the married guy, with all the friends he could possibly want, in a pretty happy town trap it? He's adventurous, cheerful, loves warriors, loves wizards and fears wampirs (I have no wampirs in town). He's got 1 enemy in town. Not sure why.... but he doesn't like Vladson (probably because he's a devious snob). But he gets together and plays bridge with the other married couple in town every Tuesday evening and they're expecting a kid. Why jeopardize the whole family by messing with the town? ;)

Annnnnd…similarly… in a town that's overwhelmingly happy and well-fed, why would long-time trusted members sabotage the town? In a world like zombasite that's literally hurting the hand that feeds & protects you. Newer members should be more likely than established long-time members to sabotage the town. Lower trust, infiltration of spies, etc. Especially true of marrieds. Why risk the whole family by sabotaging the town?

Marrieds could have babies if species-compatible. They'd be "shrunk" for a while. LOL And start out at level 0 or 1.

People out adventuring with you or out hunting shouldn't see someone in the town doing something suspicious. And if something happens in the town while they're out of town, they shouldn't be a suspect. That's just too conspicuous and unrealistic. Why would you pick on the guy with the rock-solid alibi? And how would the person you're adventuring with have the time to conspire or plant traps etc.? They're on a pretty tight leash.

Slow Pace doesn't seem to be working very well — like enough to warrant the xp penalty. I killed the level boss almost first thing. Another dreaded enemy P2 showed up, I killed him. But the quests are piling up almost per usual....? You'd think killing level bosses would slow things even more. I beelined to them and took them out.... geez. The whole area should quake in fear at my passage lol (no zombasite).

Someone trapped the town. It's obviously Silentshade Trueshade or Salir Trueshade. And amongst the people testifying against them is their spouse....??!? Look, if this is the case I hope the spouse isn't angry when I kick their butt. Hard to know which one it is. Could kick them both out. :P But I don't understand why someone would testify against someone they have over a 95 relation with.

Why does it take so much cash to bribe merchants to go to your town? "Not only will I feed you and give you a warm safe(r) place to stay, but I'll bribe you with all this money" — hrm. lol Maybe paying travel expenses? Then maybe base the amount on the length & danger of the route to town? If you've wiped clean everything between merchant and the town, it should be cheaper. Or if they're already close to your town. Just curious. What salesperson doesn't want a captive audience and a free hotel room? lol

fbo 12-30-2017 12:26 PM

On the relations screen: If "Hide eliminated" is checked, the tooltips for the clans don't show up anymore.

Crisses 12-30-2017 12:50 PM

This is from the Steam forum:
"can't remove my clanners who are guarding from their guarding duty. It says "npcs outside of town can only guard". Tried recruiting them to my party and then changing their duty, no dice."

I've encountered this glitch. The problem is that their HOUSING is outside the walls.

Now that there's more town configurations, when you move to the next/new town, the housing assignments don't change although the map changes. So now there's folk living outside the walls, and they're kinda stuck outside town in terms of certain game features. I figured it out, moved them into housing. But of course, it's still a glitch/problem even though there's a workaround. Most people wouldn't know where to look at first to figure out that they live outside the walls of town. :/

Someone on Steam answered the issue, here's the link to the Glitches thread for anyone curious:

Crisses 12-30-2017 04:17 PM

1 Attachment(s)
Back in that same level, came in via a different route — I've got guys blowing calls to battle, and constant ambushes and cave-ins. So much for getting that teleport stone lol —*that's just unplayable.

Powerfinder 01-01-2018 04:37 PM

It seems that the personal healthstone does not work properly. NPC returns to life (after reload AFAIR), but loses its name, skills and personal traits.

Sometimes there is a message that Din awarded me a chest for the destruction of the evil clan, but the chest is nowhere to be found.

Statistics indicate that the chance for a critical strike for my deathknight is 57.97%. He easily produces long rows of 20+ critical hits. But if the chance for a critical strike is 57.97%, then the probability of such a series is 0.5797 ^ 20 = 0.00001836817 (ie not very common event). It looks like a bug. Or am I missing something?

All times are GMT -4. The time now is 06:17 AM.

Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright © 2007 - 2019 Soldak Entertainment, Inc.