Soldak Entertainment Forums

Soldak Entertainment Forums (http://www.soldak.com/forums/index.php)
-   Linux (http://www.soldak.com/forums/forumdisplay.php?f=35)
-   -   Linux Drox Operative on Steam (http://www.soldak.com/forums/showthread.php?t=31116)

Shadow 04-26-2016 12:56 PM

You could double click on the executable directly and see if that helps. I believe the log will be ~/.local/DroxOperative/User/log.txt which should have some useful info of where it thinks various directories are.

Hwesta 06-17-2017 11:00 PM

Sorry for taking so long to get back to this, I got distracted with other games.

No directory named '~/.local/Zombasite' exists. However, there is a '.local/DroxOperative/User/log.txt' file with timestamps indicating it's touched when Steam runs Drox, which contains 3 lines:

Code:

Couldn't find translation file lang/layoutLinux.loc!
Couldn't find keynames file lang/keyNames.loc!
Safe and dependant systems initialized

When I try running DroxOperative directly, it gives an error about libsteam_api.so, even though that is in the directory:

Code:

$ pwd
/home/hwesta/.local/share/Steam/SteamApps/common/Drox Operative
$ ls
Assets  changes.txt  DroxOperative  EULA.txt  FontLicense.txt  libsteam_api.so  manual.txt  OtherLicenses.txt  User
$ ./DroxOperative
./DroxOperative: error while loading shared libraries: libsteam_api.so: cannot open shared object file: No such file or directory

If I watch Steam's output when failing to start Drox, there's nothing that looks like an error.

Hwesta 06-17-2017 11:46 PM

Poked at it some more and got it working.

1) strace tells me that DroxOperative executable isn't looking for libsteam_api.so in the same directory. If I symlink libsteam_api.so to a location that DroxOperative executable is looking for, it gives me the same error as when I run it through Steam ("Couldn't find Database/database.dbl!"). This is a red herring, and is not needed to get Drox Operative to run in Steam.
2) strace shows that DroxOperative executable is looking for files like "Database/database.dbl", but never touches "Assets/assets001.zip" to extract them. I tried extracting the contents of "Assets/assets00*.zip" into that directory
3) When extracting "Assets/assets003.zip" it extracts files with the same name. These have to replace the files previously generated. Eg:
Code:

$ unzip assets003.zip
Archive:  assets003.zip
replace Loc/English/global.trn? [y]es, [n]o, [A]ll, [N]one, [r]ename: A

When I did all three of those things, the game starts when running the executable directly. I can remove the symlink for libsteam_api.so and the game runs fine through Steam, so Steam must be setting the path correctly.

In short, to get it running on Arch:

1) Go to "~/.local/share/Steam/SteamApps/common/Drox\ Operative/Assets"
2) Unzip the 3 assets files there, ensuring that assets003.zip is extracted last

Hwesta 06-18-2017 12:02 AM

I think I spoke too soon, unfortunately. The game starts up, but only displays the background auto-battle. There is no menu, and nothing to interact with. The resolution is a fixed-size that looks like 800x600.

Now the log file at ~/.local/DroxOperative/User/log.txt has:

Code:

Safe and dependant systems initialized
Database parsed
Graphics system initialized
Opened OpenAL Soft Device
Using 256 sound sources
Sound system initialized
Could not find menu HelpBottom
Could not find menu HelpTop
Could not find menu WorldMap
Could not find menu WorldMap
Could not find menu WorldMap
Could not find menu WorldMap
Could not find menu Editor
Could not find menu Editor
Could not find menu ModelEditor
Could not find menu ModelEditor
Could not find menu ModelEditor
Input initialized
Debug system started
Done initializing
Graphics system initialized
Input initialized
Graphics system initialized
Input initialized


Shadow 06-19-2017 12:46 PM

It still sounds like it just isn't finding some things correctly. I'm curious what directories it's trying to read from.

Open your user.cfg (same directory as log.txt) and change developer value to 1, run the game again, and then post the first part of log.txt that has the directory info, if you could.

Hwesta 06-19-2017 02:23 PM

Code:

Asset dir - /home/hwesta/.local/share/Steam/SteamApps/common/Drox Operative/Assets
Asset writable dir - /home/hwesta/.local/DroxOperative/Assets
Asset user writable dir - /home/hwesta/.local/DroxOperative/Assets
Readonly user dir - /home/hwesta/.local/share/Steam/SteamApps/common/Drox Operative/User
Writable user dir - /home/hwesta/.local/DroxOperative/User

"/home/hwesta/.local/DroxOperative/Assets" doesn't exist, though all the other directories do. Creating the ".local/DroxOperative/Assets" directory, and populating it with the assets.zip files or their contents also didn't do anything.

Thanks for helping troubleshoot this.

sss123next 09-28-2019 05:12 PM

i have release from gog and have same problem, but this is regression in latest version, i have older version installed which is still working fine.


All times are GMT -4. The time now is 02:52 PM.

Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright 2007 - 2019 Soldak Entertainment, Inc.