View Single Post
  #73  
Old 01-14-2019, 05:03 PM
Excellion Excellion is offline
Amateur
 
Join Date: Aug 2012
Posts: 24
Default

Quote:
Originally Posted by Shadow View Post
The random skills in the 2nd thing is on purpose, although it isn't necessarily supposed to be tied to the map.
As far as i tried it seems to be (currently). Recreating a SpellSword trice on the same map resulted in the exact same skill set each time. Not necessarily a bad thing though. Another thing i noticed seems to be tied to the save / load system. I had a few oddball situations happen:

1. Yesterday one renegade NPC fled to an area named the "Secret tunnels" that was located under the "Secret Tunnels". It wasn't pinpoint-able on the map and seemed to have no access point anywhere. I might have missed it, though i note i fully explored all map area's thoroughly including any secret area's.
2. Yesterday i moved through a secret area gate with no initial issues. After returning to said gate after exploring the area (Without changing levels) the gate was suddenly, say, a 100 pixels further to the left and located inside a wall where it couldn't be reached.
3. Today i ran into an odd issue with the Earthquake, Earth Mastery and Blood Sacrifice skill. This combo should do 6 damage on use (38 mana, -47% mana cost reduction and 40% mana as damage on use). Today it suddenly seemed to trigger red damage numbers and each earthquake seemed to hit me for 17-31 damage with the capacity to deal a crushing blow on myself.

In all three cases i started writing a bug report, but upon a "Save and Exit" followed by a reload of the save the issues vanished (NPC was in a different area altogether, gate had moved back to its previous correct position and earthquake damage was doing 6 damage again without red damage numbers displayed).

These problems are a bit of a pain. Not due to the issues themselves, but because i dislike writing vague reports that don't include a clear description or a set of steps to reproduce the issue. In these three cases i still don't have the foggiest idea how i managed to trigger these problems, let alone why a reload fixed them each time. After the third i figured I'd mention these but i kind of doubt there is anything actionable here.
Reply With Quote