View Single Post
Old 06-18-2017, 12:46 AM
Hwesta Hwesta is offline
Join Date: Apr 2016
Posts: 6

Poked at it some more and got it working.

1) strace tells me that DroxOperative executable isn't looking for in the same directory. If I symlink to a location that DroxOperative executable is looking for, it gives me the same error as when I run it through Steam ("Couldn't find Database/database.dbl!"). This is a red herring, and is not needed to get Drox Operative to run in Steam.
2) strace shows that DroxOperative executable is looking for files like "Database/database.dbl", but never touches "Assets/" to extract them. I tried extracting the contents of "Assets/assets00*.zip" into that directory
3) When extracting "Assets/" it extracts files with the same name. These have to replace the files previously generated. Eg:
$ unzip 
replace Loc/English/global.trn? [y]es, [n]o, [A]ll, [N]one, [r]ename: A
When I did all three of those things, the game starts when running the executable directly. I can remove the symlink for and the game runs fine through Steam, so Steam must be setting the path correctly.

In short, to get it running on Arch:

1) Go to "~/.local/share/Steam/SteamApps/common/Drox\ Operative/Assets"
2) Unzip the 3 assets files there, ensuring that is extracted last
Reply With Quote