Soldak Home   Drox Operative   Din's Curse   Depths of Peril   Zombasite  

Go Back   Soldak Entertainment Forums > Din's Curse > Din's Curse game
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
  #1  
Old 01-27-2011, 05:10 PM
Shadow's Avatar
Shadow Shadow is offline
Super Moderator
 
Join Date: Jun 2007
Location: Dallas, TX
Posts: 9,412
Default Din beta patch 1.017

Beta Patch 1.017 of Din's Curse is now available over on the Din's Curse patch page. Changes can be read here. This patch contains a bunch of small fixes and some balance changes.
__________________
Steven Peeler
Designer/programmer
Depths of Peril, Kivi's Underworld, Din's Curse, Drox Operative, Zombasite, Din's Legacy, & Drox Operative 2
Patreon
Reply With Quote
  #2  
Old 01-27-2011, 07:57 PM
Max_Powers Max_Powers is offline
Champion
 
Join Date: Jul 2010
Posts: 175
Default

I was going through one of my player stashes and noticed something odd with one of the items. I believe it is Damek's Cap, but it is orange(Elite)instead of light blue(set)and the name is like this: DameksCapDameksCapFake

Nothing else seems out of place about it, but I don't have an unaffected Damek's Cap to compare to. Also, just to clarify, I do not, have not, nor do I want to try and dupe items(if possible), so that has nothing to do with this.
Reply With Quote
  #3  
Old 01-27-2011, 08:28 PM
Shadow's Avatar
Shadow Shadow is offline
Super Moderator
 
Join Date: Jun 2007
Location: Dallas, TX
Posts: 9,412
Default

It's definitely not a dupe type thing. I screwed up the name, but that's now a "fake" Damek's Cap. The "real" Damek's Cap is about 40 levels higher now if I remember correctly.
__________________
Steven Peeler
Designer/programmer
Depths of Peril, Kivi's Underworld, Din's Curse, Drox Operative, Zombasite, Din's Legacy, & Drox Operative 2
Patreon
Reply With Quote
  #4  
Old 01-28-2011, 01:37 PM
Bak's Avatar
Bak Bak is offline
Elite
 
Join Date: Dec 2008
Posts: 259
Default

I haven't update to 1.017 yet, but I don't see this on the "changes" list.

My quest list says my character is at war with the Scarabus Exploders.
But I just had a town invasion of elves, with the message
"Due to our war with the Dark Elf Priest they are attacking the town".

So either that should be a town invasion of the same type that is warring, or the message should be changed to:
"Taking advantage of our war with the Scarabus Exploders, the Dark Elf Priests are attacking the town."
Reply With Quote
  #5  
Old 01-29-2011, 12:06 PM
FloodSpectre's Avatar
FloodSpectre FloodSpectre is offline
Elite
 
Join Date: Nov 2007
Location: Rochester, New York
Posts: 397
Default

I'm pretty sure I've run into the wrong race type war issue too, but I can't quite recall. It was definitely a while ago, and only once.
Reply With Quote
  #6  
Old 02-01-2011, 12:20 PM
Hagaar Hagaar is offline
Expert
 
Join Date: Aug 2010
Posts: 61
Default Patching issues

Shadow,
Can you lease check the compatibility of the patches? I just tried to install 1017 and had to revert BACK to 1011. Thanks!

Btw, I do not have Demon Wars... yet

That should read "please". I really need more coffee before pounding the keyboard.

Last edited by Hagaar : 02-01-2011 at 12:21 PM. Reason: edit of post
Reply With Quote
  #7  
Old 02-01-2011, 01:14 PM
Shadow's Avatar
Shadow Shadow is offline
Super Moderator
 
Join Date: Jun 2007
Location: Dallas, TX
Posts: 9,412
Default

Quote:
Originally Posted by Hagaar View Post
Can you please check the compatibility of the patches? I just tried to install 1017 and had to revert BACK to 1011.
What do you mean by compatibility? Do you mean like with different hardware specs or with the base game?
__________________
Steven Peeler
Designer/programmer
Depths of Peril, Kivi's Underworld, Din's Curse, Drox Operative, Zombasite, Din's Legacy, & Drox Operative 2
Patreon
Reply With Quote
  #8  
Old 02-01-2011, 01:59 PM
Hagaar Hagaar is offline
Expert
 
Join Date: Aug 2010
Posts: 61
Default

Quote:
Originally Posted by Shadow View Post
What do you mean by compatibility? Do you mean like with different hardware specs or with the base game?
The game. I tried reinstalling the game from the disk, added the mods you have listed on the "Mods" page then installed 1017. Only to have the error message pop up telling me that it was not compatible (see my post concerning this earlier).

I had it on my laptop (Vista) then tried installing it onto my PC (XP). Same install and same issue. I've decided to uninstall the game out of frustration. But will go back at some point since I was really enjoying the game and thinking about DW.
Reply With Quote
  #9  
Old 02-01-2011, 02:10 PM
Shadow's Avatar
Shadow Shadow is offline
Super Moderator
 
Join Date: Jun 2007
Location: Dallas, TX
Posts: 9,412
Default

Quote:
Originally Posted by Hagaar View Post
The game. I tried reinstalling the game from the disk, added the mods you have listed on the "Mods" page then installed 1017. Only to have the error message pop up telling me that it was not compatible (see my post concerning this earlier).

I had it on my laptop (Vista) then tried installing it onto my PC (XP). Same install and same issue. I've decided to uninstall the game out of frustration. But will go back at some point since I was really enjoying the game and thinking about DW.
This might be difficult now, but what was the exact wording of the error?

Also which mods did you have installed?
__________________
Steven Peeler
Designer/programmer
Depths of Peril, Kivi's Underworld, Din's Curse, Drox Operative, Zombasite, Din's Legacy, & Drox Operative 2
Patreon
Reply With Quote
  #10  
Old 02-01-2011, 04:12 PM
Hagaar Hagaar is offline
Expert
 
Join Date: Aug 2010
Posts: 61
Default

Quote:
Originally Posted by Shadow View Post
This might be difficult now, but what was the exact wording of the error?

Also which mods did you have installed?
"Critical Error. Version mismatch! Please apply the latest patch (even if you have applied it before)." Is the error message.

The mods were the ones you have on the Mods Page: No Pentagrams Mod, No Abandon Penalty (as needed), No Town Attacks Mod, Brighter Dungeons Mod, Safer Cave-ins mod, Arachnophobia Mod (these are all version 1). Unlock Modes Mod (This WAS version 1. I replaced it with the current version 2).

The following are from the community: Din's Additionals, Starting Backpack, Brighter Dungeons, dungeon levels, icolor and Stack.

I had downloaded the latest version of the patch and applied it AFTER installing Ver 2 of Unlocks Mod.
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 12:18 PM.


Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright 2007 - 2019 Soldak Entertainment, Inc.