Soldak Home   Drox Operative   Din's Curse   Depths of Peril   Zombasite  

Go Back   Soldak Entertainment Forums > Zombasite > Zombasite
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
  #1  
Old 02-20-2018, 06:27 AM
wrestless wrestless is offline
Expert
 
Join Date: Apr 2013
Posts: 59
Default frequent crashes - soundcard related?

Hi, firstly many thanks for the game and the superb expansion. Despite being a bit rough around the edges, it's endlessly fun, and I adore how dynamic and unpredictable it can be.

Unfortunately, I've been plagued by the game crashing, and it seems to have become more frequent since the last patch. It used to happen maybe once every couple of hours, but now I can only play for a few minutes before it crashes and it's killing the enjoyment.

What happens is the game hangs and then I get the Windows alert "Zombasite.exe has stopped responding."

I think it could be soundcard-related because it seems to occur when a new sound effect could be expected i.e. when I click to attack an enemy, when I trigger a trap, when I enter a new map area etc.

So far I've tried:
  • reinstalling Zombasite
  • disabling and re-enabling the soundcard in Device Manager
  • trying different soundcards (High Definition Audio Device, NVIDIA High Definition Audio, Sound Blaster Play! 2)
  • checking for updated drivers
  • disabling all sound enhancements (in Control Panel > Sound > Enhancements)
  • trying the different sound options in Zombasite (DirectSound3D, DirectSound, MMSYSTEM)
  • running Zombasite as Administrator
  • running Zombasite in compatibility mode
  • not loading startup items & services (clean startup) to prevent other programs running in the background

For now I've disabled my default soundcard and am using "NVIDIA High Definition Audio", as that seems to crash less often. It means I can't use my speakers, but at least I can play a little.

My system:
Windows 10 Pro
Intel i5-2400 @ 3.10 GHz
8 GB RAM
NVIDIA GeForce GTX 750 Ti


Any suggestions on what else I can try? I haven't experienced this problem with any other games/applications.

Incidentally, I run Zombasite via Steam, whereas I played Din's and Drox as standalone games. Would I need to repurchase Zombasite to play it independent of Steam?

Last edited by wrestless : 02-20-2018 at 06:28 AM. Reason: OCD
Reply With Quote
  #2  
Old 02-20-2018, 10:10 AM
Shadow's Avatar
Shadow Shadow is offline
Super Moderator
 
Join Date: Jun 2007
Location: Dallas, TX
Posts: 8,823
Default

You could change s_initSound to 0 in your user.cfg to turn off sound and see if that is really what is causing your crashes. You could also email me your save game and I could check it out and see if I can get it to crash.
__________________
Steven Peeler
Designer/programmer
Depths of Peril, Kivi's Underworld, Din's Curse, Drox Operative, Zombasite, & Din's Legacy
Patreon
Reply With Quote
  #3  
Old 02-20-2018, 03:45 PM
wrestless wrestless is offline
Expert
 
Join Date: Apr 2013
Posts: 59
Default

Thanks Steven.

It's not just one save file that's affected. If I create a new character, the same thing happens. So I assume the problem is with Windows, not the save files?

I've edited user.cfg and I'll let you know if that fixes the problem.
Reply With Quote
  #4  
Old 02-20-2018, 05:01 PM
Shadow's Avatar
Shadow Shadow is offline
Super Moderator
 
Join Date: Jun 2007
Location: Dallas, TX
Posts: 8,823
Default

Yeah, if it happens with every character, it's not character related. It could possibly be related to the persistent save stuff though. But like you are suspecting it is probably more likely to more computer related.
__________________
Steven Peeler
Designer/programmer
Depths of Peril, Kivi's Underworld, Din's Curse, Drox Operative, Zombasite, & Din's Legacy
Patreon
Reply With Quote
  #5  
Old 02-21-2018, 06:59 AM
wrestless wrestless is offline
Expert
 
Join Date: Apr 2013
Posts: 59
Default

It worked!
When I changed s_initSound to 0, I couldn't get the game to crash.
When I changed it back to 1, it crashed within 10 minutes.
All other variables were the same.

I was surprised how playable the game is with no sound. So kudos for that!

Does anyone have any ideas on what I can do to fix the problem, accepting that the issue is my computer and not the game?
Reply With Quote
  #6  
Old 02-21-2018, 07:05 AM
wrestless wrestless is offline
Expert
 
Join Date: Apr 2013
Posts: 59
Default

Quote:
Originally Posted by Shadow View Post
It could possibly be related to the persistent save stuff though.
If I deleted all the content of the "chars" folder, would that test whether it was related to the persistent save stuff? Or are you referring to something else?

(It may not help, but it's probably worth trying before I reinstall Windows or throw my computer out the window. )
Reply With Quote
  #7  
Old 02-21-2018, 12:11 PM
Shadow's Avatar
Shadow Shadow is offline
Super Moderator
 
Join Date: Jun 2007
Location: Dallas, TX
Posts: 8,823
Default

Quote:
Originally Posted by wrestless View Post
If I deleted all the content of the "chars" folder, would that test whether it was related to the persistent save stuff? Or are you referring to something else?
Yes, but I would just rename the directory so you still had access to all your old characters if you wanted.
__________________
Steven Peeler
Designer/programmer
Depths of Peril, Kivi's Underworld, Din's Curse, Drox Operative, Zombasite, & Din's Legacy
Patreon
Reply With Quote
  #8  
Old 04-02-2018, 09:06 AM
wrestless wrestless is offline
Expert
 
Join Date: Apr 2013
Posts: 59
Default

I'm still getting frequent game crashes.
I tried deleting all the saved game data, and I've tried resetting Windows 10, but neither helped. The BIOS diagnostic tools can't find anything wrong with my hardware.

I tried running Zombasite when Windows was in Safe mode. I thought that may give me more details about why it crashes. But the game was unplayable due to the lack of graphics/textures. I think my character died within a minute because I couldn't work out what was going on, lol.

Here's the Zombasite\User\log.txt output that was created:
Code:
Safe and dependant systems initialized
Database parsed
Compressed textures not supported
OpenGL version - 1.1.0
Couldn't find Textures/black.rtx
Couldn't find Textures/white.rtx
Couldn't find Textures/circle.rtx
Couldn't find Textures/UI/gradiant_white.rtx
Couldn't find Textures/Icons/questAvailable.rtx
Couldn't find Textures/Icons/questCompleted.rtx
Couldn't find Textures/Icons/recruitAvailable.rtx
Couldn't find Textures/Icons/betterItem.rtx
Couldn't find Textures/Icons/replaceItem.rtx
Couldn't find Textures/UI/ui_icons/cargoBayOpen.rtx
Couldn't find Textures/Icons/notMetYet.rtx
Couldn't find Textures/Icons/notMetYetTemp.rtx
Couldn't find Textures/UI/ABottom2.rtx
Couldn't find Textures/Icons/dynamicDialogAvailable.rtx
Couldn't find Textures/Icons/Clans/nemesis.rtx
Couldn't find Textures/Icons/Clans/archNemesis.rtx
Couldn't find Textures/UI/ui_icons/rarityCommon.rtx
Couldn't find Textures/UI/ui_icons/rarityRare.rtx
Couldn't find Textures/UI/ui_icons/raritySet.rtx
Couldn't find Textures/UI/ui_icons/rarityElite.rtx
Couldn't find Textures/UI/ui_icons/rarityArtifacts.rtx
Couldn't find Textures/UI/ui_icons/rarityLegendary.rtx
Couldn't find Textures/shadow.rtx
Couldn't find Textures/UI/loading01.rtx
Couldn't find Textures/Fonts/Gentium12.rtx
Couldn't find Textures/Fonts/Gentium16.rtx
Couldn't find Textures/Fonts/Gentium20.rtx
Couldn't find Textures/Fonts/Gentium24.rtx
Couldn't find Textures/Fonts/Gentium32.rtx
Couldn't find Textures/Fonts/Gentium40.rtx
Couldn't find Textures/Fonts/Gentium48.rtx
Couldn't find Textures/Fonts/Gentium10.rtx
Couldn't find Textures/Fonts/Gentium8.rtx
Graphics system initialized
Failed to open sound device!
Is that what you would expect when trying to play Zombasite in Windows 10 Safe Mode? Or is that indicative of some sort of problem that could be causing it to crash?
Reply With Quote
  #9  
Old 04-02-2018, 11:34 AM
Shadow's Avatar
Shadow Shadow is offline
Super Moderator
 
Join Date: Jun 2007
Location: Dallas, TX
Posts: 8,823
Default

I actually have never tried playing any of our games in safe mode. Missing textures shouldn't crash the game.
__________________
Steven Peeler
Designer/programmer
Depths of Peril, Kivi's Underworld, Din's Curse, Drox Operative, Zombasite, & Din's Legacy
Patreon
Reply With Quote
  #10  
Old 04-17-2018, 06:05 PM
Psyk0's Avatar
Psyk0 Psyk0 is offline
Expert
 
Join Date: Jun 2007
Location: QC, Canada
Posts: 39
Default

Going out on a limb here...

Are you overclocking your system at all, specifically CPU? If so are you using a tool (something like Asus AI suite or whatever is used these days) to change clock speed while in windows 10 and not the BIOS itself?
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 12:32 PM.


Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright 2007 - 2019 Soldak Entertainment, Inc.