Soldak Home   Drox Operative   Din's Curse   Depths of Peril   Zombasite  

Go Back   Soldak Entertainment Forums > Din's Curse > Din's Curse game
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
  #1  
Old 12-14-2015, 06:16 AM
erez erez is offline
Amateur
 
Join Date: Mar 2011
Posts: 8
Default Linux sound issue

I've installed the gog.com release on my Arch linux computer, and the game runs (nearly) perfectly, apart from one issue. If I run it with sound on, it closes upon start with a "Sound failed to initialize" error message. Once sound is turned off, as mentioned, the game runs perfectly.

I would like to attempt to enable sound on it, though. Did anyone had a similar problem and managed to fix it? Maybe there's a specific library I need to use? What is the component that runs the sound?

Any help would be appreciated.
Reply With Quote
  #2  
Old 12-14-2015, 02:10 PM
Shadow's Avatar
Shadow Shadow is offline
Super Moderator
 
Join Date: Jun 2007
Location: Dallas, TX
Posts: 8,272
Default

We use OpenAL on Linux (specifically libopenal1 I believe).
__________________
Steven Peeler
Designer/programmer
Depths of Peril, Kivi's Underworld, Din's Curse, Drox Operative, & Zombasite
Reply With Quote
  #3  
Old 12-14-2015, 05:44 PM
erez erez is offline
Amateur
 
Join Date: Mar 2011
Posts: 8
Default

Hey, actually I managed to fix the issue, by looking into the lib library and installing a couple of other 32-bit libraries. So now my enjoyment is complete.
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 07:59 AM.


Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2007 - 2016 Soldak Entertainment, Inc.